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Course Creation

Moodle Login page:

Adding a course

o By default a regular teacher can't add a new course. To add a new course

to Moodle, you need to have either Administrator, Course

Creator or Manager rights.

● To add a course:

o From the Site administration link, click Courses>Manage courses and

categories

https://docs.moodle.org/34/en/Administrator
https://docs.moodle.org/34/en/Course_creator
https://docs.moodle.org/34/en/Course_creator
https://docs.moodle.org/34/en/Manager


o Click New course in the category page on the right

o Click on the category where you want your course to be. For more

information see Course categories

o Click the "New course" link

o Enter the course settings, and then choose either to "Save and return" to

go back to your course, or "Save and display" to go to the next screen.

o On the next screen, if you have chosen "Save and display", choose your

students/teachers to assign to the course.

Deleting a course

o Teachers cannot delete courses.

https://docs.moodle.org/34/en/Course_categories
https://docs.moodle.org/34/en/Course_settings


o Managers (i.e. users with a role for which the

capability moodle/course:delete is allowed) can delete courses and course

creators can delete courses they have created themselves, but only within

24 hours of creating the course.

o This is so that courses created by mistake may be deleted without

needing to ask an administrator.

o Administrators can always delete courses.

● To delete a course (as an admin or manager):

o From the Site administration link, click Courses > Manage courses and

categories

o Click the course's category and click the course in the screen on the right.

o Click the Delete link.

● You can delete multiple courses by:

o Creating a new (temporary) category. You can name it "To be deleted".

o Select and move the "About to be deleted" courses to that category ("To

be deleted").

o Delete the category ("To be deleted") and choose "Delete ALL - cannot be

undone".

Sorting courses

o Courses may be sorted by an admin or manager from Administration>Site

administration>Courses>Manage courses and categories.

o Courses may be sorted by ascending/descending and by time created.

https://docs.moodle.org/34/en/Capabilities/moodle/course:delete
https://docs.moodle.org/34/en/Course_creator
https://docs.moodle.org/34/en/Course_creator


Course requests

o The course request feature can be enabled by an administrator

in Administration > Site administration > Courses > Course request.

o An admin can set the default category for course requests, whether users

can select a category when requesting a course, and who can receive

notification of course requests (from a list of users with the

capability moodle/site:approvecourse).

o A 'Request a new course' button will then appear on the 'All courses'

page. The All courses page can be accessed via a link in the Courses

block.

https://docs.moodle.org/34/en/Capabilities/moodle/site:approvecourse
https://docs.moodle.org/34/en/Courses_block
https://docs.moodle.org/34/en/Courses_block


o If course requests are enabled, by default all authenticated users can

make course requests.

Bulk course creation

o For full details on how to bulk create courses and use course templates,

see Upload courses.

o Go to Administration > Site Administration > Courses > Upload courses.

o Upload a CSV file either by dragging and dropping or using the button to

select from the File picker.

o Select your import options and click Preview. If the settings are

acceptable, click Upload.

Course templates

o It is possible, from Administration>Site Administration>Courses>Upload

courses to specify a course and settings to use as template for future

courses.

o Default blocks for new courses can also be configured in config.php.

Using an existing course as a template

o First, create or locate on your Moodle the course you wish to use as a

template and make a note of its shortname. A template course might for

https://docs.moodle.org/34/en/Upload_courses


example have common headings or section summaries or policy

agreements used throughout the site for consistency.

o Note that only the content of the course will be restored; not its settings.

Settings are added separately.

Method 1

o Create your csv file. See Upload courses for accepted fields.

o From the Site administration link, click Courses>Upload courses and add

your file.

o Preview it and scroll down to 'Course process'. In the box 'Restore from

this course after upload', add the shortname of your template course.

o If you are creating several courses using the same template and you wish

them all to have the same settings, you can specify these in the Default

course values.

o Upload your csv file.

Method 2

o All the settings and the chosen template course can be specified in the

csv file you create. Use templatecourse as the field for your chosen

template course, and use the course shortname.

o Here is an example of a csv file for restoring a course to be used as a

template. It specifies for example the theme, language, enrolment method

and alternative names for student and teacher.

o shortname,fullname,category,newsitems,theme,lang,format,enrolment_1,e

nrolment_1_role,role_student,role_teacher,templatecourse

o Knit,Knitting,2,0,afterburner,fr,topics,manual,student,NewKnitter,MasterKni

tter,OMT

o Go to Administration>Site administration>Courses>Upload courses and

add your csv file.

Using a backup course as a template

o It is possible during the process of creating courses with a csv file in Site

administration>Administration>Courses>Upload courses to specify and

upload a backup file to be used as a template.

https://docs.moodle.org/34/en/Upload_courses


o Create your csv file. See Upload courses for accepted fields.

o From Site administration>Administration>Courses>Upload courses, add

your file.

o Preview it and scroll down to 'Course process'. In the box 'Restore from

this file after upload', add the backup file you wish to use as the template.

o If you are creating several courses using the same template and you wish

them all to have the same settings, you can specify these in the 'Default

course values' section.

o Alternatively, you can specify the course settings (such as format,

enrolment methods, language) in the csv file. This method is useful if you

wish different courses using the same template to have different settings.

o Upload your csv file.

Enabling the use of restrict access sitewide

To use the restrict access feature, it must be enabled by an administrator by checking

the "Enable conditional access" box in Administration > Site administration > Advanced

features. A restrict access section will then appear for teachers on the Activity settings

screen, with an 'Add restriction' button. This section applies to all activities and

resources, and is the second to last section in each activities settings area,

above Activity completion (if it has been turned on).

https://docs.moodle.org/34/en/Upload_courses


Enabling or disabling specific restrictions

In Site administration > Plugins > Availability restrictions > Manage restrictions you can

enable or disable (Hide/Show)any of the individual restriction types for use throughout

the site.

Restricting activity access

In the settings of each activity there is a Restrict Access section. To get to this, click

'Edit' alongside the activity you want to restrict and then choose 'Edit Settings', or add a

new activity, which will bring you to the settings page.

In the 'Restrict Access' section of the activity settings page, click the 'Add restriction'

button. A choice of conditions appears:



Restriction can be based upon Activity completion, date, grade, the group or grouping

the students are in or even user profile fields. The 'Restriction set' button also allows for

more complex criteria requiring nested conditions.

Activity completion

Note that this button only appears if you have Activity completion enabled by the

administrator in your site, and it is enabled in your course in Course administration >

Edit settings > Completion tracking.

Date

Access can be restricted from or until a certain date and time.

Grade

You can specify a condition on any grade in the course: the full course grade, the grade

for any activity, or a custom grade that you create manually. You can enter either a

minimum value (at least percentage), a maximum value (less than percentage), both, or

neither. The activity will only appear if the student has a value for the specified grade,



and if it falls within any specified number range. You can add more than one grade

condition. All conditions must be met in order for the activity to appear.

● The range numbers can be fractional (with up to five decimal places) if necessary.

● Be careful with the maximum value; if the maximum is 7, a student who scores

exactly 7 will not see the activity. You could set it to 7.01 if you really wanted to

include 7.

● If creating several different activities that appear according to grade ranges, use the

same number for the maximum of one activity, and the minimum of the next. For

example, you might create one activity with a maximum of 7 and another with a

minimum of 7. The first would appear to everyone scoring between 0 and 6.99999,

and the second would appear to everyone scoring 7.00000 to 10. This guarantees

that everyone with a grade will see one or other.To remove a grade condition, set

the assessment name to 'none' and remove the range number values

● If you want to use a condition for students with blank grades then you can add a

grade restriction and select the activity you want to use as a restriction. Do not

select a checkbox for either the greater than or less than criteria. This will require

the student to have a grade. This means students with blank grades do not meet

that criterion.

Group and groupings

If groups or groupings are used in the course, it is possible to restrict the activity to a

certain group or grouping. If they are turned off for this course and not available, these

options will not be present for use as an restriction.

NOTE: This button only appears if you have groups enabled in your course.

User profile



Access can be restricted using one of the following user fields:

● Address - This is the value in the 'address' column

● AIM ID - This is the value in the 'aim' column

● City/town - This is the value in the 'city' column

● Country - This is the two letter country code, NOT the name of the country.

● Department - This is the value in the 'department' column

● Email Address - This is the value in the 'email' column

● First name - This is the value in the 'firstname' column

● ICQ number - This is the value in the 'icq' column

● ID number - This is the value in the 'idnumber' column

● Institution - This is the value in the 'institution' column

● Mobile phone - This is the value in the 'phone2' column

● MSN ID - This is the value in the 'msn' column

● Phone - This is the value in the 'phone1' column

● Skype ID - This is the value in the 'skype' column

● Surname - This is the value in the 'lastname' column

● Web page - This is the value in the 'url' column

● Yahoo ID - This is the value in the 'yahoo' column

Restriction set

This allows you to add a set of complex restrictions to apply complex logic. See Using

restrict access for an example.

Hiding the conditions

● If the eye is SHUT then students who do not meet that part of the condition will not

see the activity at all.

● If the eye is OPEN the students who do not meet that part of the condition will see

the activity but it will be greyed out and have information about why they can't

access it yet.

The shut eye takes precedence. For example, you could have 2 conditions, one based

on date (with eye shut) and one based on completing a previous activity (with eye



open). That way, the activity will not appear at all until the date; then it will appear, but

tell you that you need to complete the other activity; then when you complete the other

activity you can access it.

For OR and NOT AND type conditions, you only get a single eye icon instead of one for

each condition

ALL or ANY Conditions

Further restrictions may be added by clicking the 'Add restriction' button again, and it is

possible to specify that ALL the conditions or ANY of the conditions are required before

the activity is made available. Thus, it is possible to use 'Or' as well as 'And' conditions.

See Using Conditional activitiesfor an example.

'and' condition 'or' condition

Restricting whole course section access

It is possible to restrict access to activities and resources within a whole course section

by specifying the conditions in the settings for that particular section. Do this by editing

the section settings in Topic menu > Edit topic > Restrict access.

https://docs.moodle.org/33/en/Using_Conditional_activities


Moodle Quiz

How a Moodle quiz works

Once a quiz has been added to the course and the Quiz settings established,the

teacher can start to build the quiz. The teacher can access the quiz to edit the questions

by clicking directly on the Quiz name on the course home page or by clicking "Edit quiz"

in Administration>Quiz administration.(You can also make questions in the Question

bank without first creating a quiz. These questions may then be used later.)



Adding questions

Once you have accessed the quiz editing screen as above, you can add questions from

a number of locations:

1. Click the 'Add' link as in the screenshot below. (Note that in the US, the term

'marks' is replaced by 'points'.)

2. When it opens up, choose either to add a new question, to select a question

from the question bank or to add a random question.

Creating a new question

1. To make a brand new question, click 'Add' and then '+ a new question'.

2. From the next screen, choose the question type you want to add and click "Next"

('When you click on a question type on the left, helpful information appears on the right.

)



Selecting a question type

3. Fill in the question form, making sure to give a grade to the correct answer.

4. Click "Save changes".

A question when it has been created

When a question has been created, an icon and words display its type (eg multiple

choice). It can be modified by clicking the edit icon (eg ) and previewed by clicking

the magnifiying glass icon.

As well as deleting individual questions with the delete (bin/trash can) icon, it is possible

to delete more than one question by pressing the 'Select multiple items' button and

choosing the questions to be removed:

Adding responses and feedback

5. When you add responses and feedback, remember you can expand the toolbar to

show more buttons.



6. You can continue adding questions this way, clicking 'Add' and '+ a new question'

each time.

Choosing a pre-made question

● If other teachers in the course have made questions, or if a teacher made questions

in an earlier quiz, these can be added to the current quiz by clicking 'Add' and '+

from question bank' .

● Click the + sign next to one question you want to add it (1 in screenshot below)

● If you have several questions, or you want to add all the questions, tick the box of

each question or the top box (2 in screenshot below) and then click 'Add selected

questions to the quiz' (3 in the screenshot below).

● To sort the questions, click the column headings. The default sort order (T) is short

for question type. (2 in the screenshot below)

● To ensure all previously made questions are available, make sure to tick the boxes

"also show questions from sub-categories/old questions".

Using a previously made question

Note: It is also possible to import pre-made questions into your quiz, from Quiz

administration>Question bank>Import. 



Adding a random question

As long as you have questions in the question bank, you can add random questions to

your quiz by clicking 'Add' and then '+ a random question'. This might be useful if you

have students in a class taking a quiz at the same time, because they are unlikely to get

the same questions at the same time. The same question will never appear twice in a

quiz. If you include several random questions then different questions will always be

chosen for each of them. If you mix random questions with non-random questions then

the random questions will be chosen so that they do not duplicate one of the

non-random questions. This does imply that you need to provide enough questions in

the category from which the random questions are chosen, otherwise the student will be

shown a friendly error message.

o The grade for the randomly chosen question will be rescaled so that the

maximum grade is what you have chosen as the grade for the random

question.

o You can add one or more random questions by choosing the number and

category in the question bank. Note the die icon to highlight random

question selection.

Adding a random question

Random question selected for quiz

Question categories



Questions can be stored and retrieved from categories in the Question bank. When you

make a new question it defaults to the category with the course name. So if you make a

quiz in the Senior Physics course, questions will automatically be added to "Default for

Senior Physics". You can opt to have your quiz questions in a category of their own

("Quizname") or to add a subcategory.

To add a subcategory, go to Administration>Quiz administration>Question

bank>Categories For more information on question contexts and categories,

see Question bank

Users will have access to different categories according to their permissions. For

example, a regular teacher might only have access to question categories in his own

Physics course whereas his Faculty Head of Science with permissions in all science

courses might have access to question categories in Biology and Chemistry as well.

Quiz layout

● You can choose in the Layout section of the quiz settings whether to have a new

page for every question or after a certain number of questions.

● You can add a page break between questions by clicking the arrow icon (where the

arrows are pointing away from each other) (1 in the screenshot below) A new page

will be created. (2 in the screenshot below)

● You can remove pages by clicking the arrow icon (where the arrows are pointing

towards each other). (3 in the screenshot below)

● You can also change the layout of the whole quiz by clicking the 'Repaginate' button:



● Questions may be moved by dragging and dropping using the crosshairs icon: 

Section headings

● Section headings may be added to each new page.

● For the first page, click the 'pencil' icon at the top (1) and add your heading (2):

● For other pages, click the 'Add' link (1) and choose 'a new section heading' (2), and

then add your heading as for Page 1:



● The section headings are displayed in the Quiz navigation block:

Randomizing the order questions appear

● The order in which questions appear to the student may be randomised or 'shuffled'

by ticking the 'Shuffle' box at the top of the screen:

● Where questions are in different sections (see Section headings above), each

section has its own 'Shuffle' box to tick. This means that you can mix up questions

on one section, but in another section, where their order is important, you can keep

them in the order you need them to display:



Making questions conditional upon other questions

● If using the Interactive with multiple tries or Immediate Feedback behaviour and with

the navigation method set to 'Free', it is possible to make the display of a question

dependent on a previous question being answered first.

● The question editing page will display padlock icons to the right of each question:

Padlocks - all unlocked

● If you want to make a question, for example Q2, conditional upon answering Q1,

then click the padlock just above Q2:



Padlocks - Q2 locked

● When a student accesses the quiz, they will see a message that Q2 is not available

until they give a response to Q1:

● In the Quiz navigation block, Q2 will be greyed out:

● In the following example, note that, Q1 follows a description, and a description

'questions' cannot be finished. Therefore, Q1 cannot depend on the previous

question. Similarly, Q4 follows an Essay question. The Essay cannot be finished

during the attempt, so the following question cannot depend on it. Note the lack of

padlocks in the following screenshot because of the description and Essay question:



Assigning points to questions

Administration > Quiz administration > Edit quiz > Editing quiz

You can set how many points each question is worth by changing the number in the box

to the right of each question and you can change the maximum grade by changing the

number in the box top right at the top of the quiz. The default is one point per question

and 100.00 maximum grade.

Points per question and max grade

The quiz module will do any maths, so for example, a 2 point question will be worth 2

times more when the Quiz module determines how many point out of 10 to award the

student.

Previewing the quiz

● You can preview individual questions by clicking the magnifying glass icon.

● You can preview the whole quiz by clicking the "Preview" link in Administration>Quiz

administration>Preview

● The quiz works like a real quiz so you can see your grades and any feedback for

correct/incorrect answers just as a student would see them.

NOTE: To get a more accurate view of how a student would view your quiz, it is advised

to log in with a "dummy" student account created by the admin for testing activities. This

is more reliable than the 'switch role to student' feature.



Previewing a single question

Click to preview the

whole quiz

Quiz in preview mode

After quiz has been attempted

If one or more students have taken the quiz, you will see a list of all the questions in the

quiz and a notice saying that you cannot add or remove questions.

You can change the order of questions, regrade them, preview an individual question

and click on an question edit link that will allow you to directly edit the question stored in

the question bank.

Dealing with faulty questions

There are several ways to deal with "bad" questions in a quiz.

● Change the grade for the bad question to 0 in the quiz.

● Edit the question, changing what you will accept as a correct answer, then

regrading the exam. Remember when changing a question that the next time

it is used it will be as it was in the last edit. Also, regrading will only affect one

quiz at a time.

● You can edit the question to explain the situation to the student and then you

can set the grade for the question to zero. After you make such changes you

should regrade the quiz by clicking on the Results tab and then

the Regrade tab. This will change the grade for all students who have taken



the quiz so far. Remember, if the question is used by another quiz, your

"explanation" will appear as part of that quiz.

● You can change the grade for the bad question and then move or delete the

question from your question category. The question will still appear on the

quiz. Some places do not like to delete any question, but will move them to a

"dead" or "bad" question category.

● When you discover a bad question in your quiz, it may affect the question

bank. Remember that a final might be made up of a certain number of

random questions drawn from different question categories, the same

categories used in a smaller subject quiz. It can be very important do

something about bad or invalid questions in a question category when the

categories are use in other places.

GIFT format

GIFT format allows someone to use a text editor to write multiple-choice, true-false,

short answer, matching missing word and numerical questions in a simple format that

can be imported. The GIFT format is also an export file format available in Question

bank. The format has been developed within the Moodle Community but other software

may support it to a greater or lesser degree.

General instructions

At least one blank line must be left between each question.

In the simple form, the question comes first, then the answers are set in between

brackets, with an equal sign (=) indicating the correct answer(s) and tilde (~) the wrong

answers. A hash (#) will insert a response. Questions can be weighted by placing

percentage signs (%..%) around the weight. Comments are preceded by double slashes

(//) and are not imported.

UTF-8 encoding

Any GIFT file must be correctly encoded in UTF8. You can use Microsoft's text editor

Notepad which comes with Windows to save your file in UTF-8.



Note: ANSI format will (only) work for languages without any special characters (like ä,

ö, ü, æ, å, ø, œ or ß). And don't use "Unicode" as format as this is actually UTF-16 and

won't work.

Format symbols

Here are some common GIFT symbols and their use.

Symbols Use

// text Comment until end of line (optional)

 ::title:: Question title (optional)

Text Question text (becomes title if no title specified)

[...format...] The format of the following bit of text. Options are [html],

[moodle], [plain] and [markdown]. The default is [moodle] for

the question text, other parts of the question default to the

format used for the question text.

{ Start answer(s) -- without any answers, text is a description of

following questions

{T} or {F} True or False answer; also {TRUE} and {FALSE}

{ ... =right ... } Correct answer for multiple choice, (multiple answer? -- see

page comments) or fill-in-the-blank

{ ... ~wrong ... } Incorrect answer for multiple choice or multiple answer

{ ... =item -> match ... } Answer for matching questions

#feedback text Answer feedback for preceding multiple, fill-in-the-blank, or

numeric answers

{# Start numeric answer(s)

answer:tolerance Numeric answer accepted within ± tolerance range



low..high Lower and upper range values of accepted numeric answer

=%n%answer:tolerance n percent credit for one of multiple numeric ranges within

tolerance from answer

} End answer(s)

\character Backslash escapes the special meaning of ~, =, #, {, }, and :

\n Places a newline in question text -- blank lines delimit

questions

Here are some quick examples:

// true/false

::Q1:: 1+1=2 {T}

// multiple choice with specified feedback for right and wrong answers

::Q2:: What's between orange and green in the spectrum?

{ =yellow # right; good! ~red # wrong, it's yellow ~blue # wrong, it's yellow }

// fill-in-the-blank

::Q3:: Two plus {=two =2} equals four.

// matching

::Q4:: Which animal eats which food? { =cat -> cat food =dog -> dog food }

// math range question

::Q5:: What is a number from 1 to 5? {#3:2}



// math range specified with interval end points

::Q6:: What is a number from 1 to 5? {#1..5}

// translated on import to the same as Q5, but unavailable from Moodle question

interface

// multiple numeric answers with partial credit and feedback

::Q7:: When was Ulysses S. Grant born? {#

=1822:0 # Correct! Full credit.

=%50%1822:2 # He was born in 1822. Half credit for being close.

}

// essay

::Q8:: How are you? {}

Format symbols explained

● The multiple choice format below as a comment line // for the question, when

Moodle exports it the question unique id number will appear here.

● The first set of  :: precedes the question title.

● The second :: precedes the actual question. The first { indicates the start of the

answers. The correct answer is preceded by an = sign and wrong answers by a

~. Teacher responses have a # in front of them. The question ends with a } and

then a blank line. NOTE it is { } not ( ) parenthesis! Usually these are obtained

with help of the [AltGr] key.

//Comment line

::Question title

:: Question {

=A correct answer



~Wrong answer1

#A response to wrong answer1

~Wrong answer2

#A response to wrong answer2

~Wrong answer3

#A response to wrong answer3

~Wrong answer4

#A response to wrong answer4

}

The shortest format for a multiple choice question is:

Question{= A Correct Answer ~Wrong answer1 ~Wrong answer2 ~Wrong answer3

~Wrong answer4 }

Tip: If you don't specify a question title the WHOLE question will be used as the

title at the time of import into Moodle. There are pros and cons to allowing this to

happen.

o Cons: This can add a lot of unnecessary words. This can include characters

which might confuse the export GIFT process.

o Pros: On the other hand. if the start of each question is different, it can make

finding a single question easier in a category list of questions. It will save you

typing. Having the same title for every question is a very bad idea.

Question format examples

There are several ways to use a text editor to write a GIFT format. We will try to show

the simple version for example and in some formats we will introduce some more

complex features that can be imported into many Moodle Question formats.

Multiple choice



For multiple choice questions, wrong answers are prefixed with a tilde (~) and the

correct answer is prefixed with an equal sign (=).

Here is a simple acceptable GIFT multiple choice format:

Who's buried in Grant's tomb?{=Grant ~no one ~Napoleon ~Churchill ~Mother Teresa }

Here is a longer format that uses most of the GIFT elements:

// question: 1 name: Grants tomb

::Grants tomb::Who is buried in Grant's tomb in New York City? {

=Grant

~No one

#Was true for 12 years, but Grant's remains were buried in the tomb in 1897

~Napoleon

#He was buried in France

~Churchill

#He was buried in England

~Mother Teresa

#She was buried in India

}

Multiple choice with multiple right answers

That is, using checkboxes, not radio buttons:

What two people are entombed in Grant's tomb? {

~%-100%No one

~%50%Grant

~%50%Grant's wife

~%-100%Grant's father



}

True-false

In this question-type the answer indicates whether the statement is true or false. The

answer should be written as {TRUE} or {FALSE}, or abbreviated to {T} or {F}.

// question: 0 name: TrueStatement using {T} style

::TrueStatement about Grant::Grant was buried in a tomb in New York City.{T}

// question: 0 name: FalseStatement using {FALSE} style

::FalseStatement about sun::The sun rises in the West.{FALSE}

Short answer

Answers in Short Answer question-type are all prefixed by an equal sign (=), indicating

that they are all correct answers. The answers must not contain a tilde.

Here are two examples using the simple method showing possible right answers for

credit.

Who's buried in Grant's tomb?{=Grant =Ulysses S. Grant =Ulysses Grant}

 

Two plus two equals {=four =4}

If there is only one correct Short Answer, it may be written without the equal sign prefix,

as long as it cannot be confused as True-False.

Matching

Matching pairs begin with an equal sign (=) and are separated by this symbol "->".

There must be at least three matching pairs.

Match the following countries with their corresponding capitals. {



=Canada -> Ottawa

=Italy -> Rome

=Japan -> Tokyo

=India -> New Delhi

}

Matching questions do not support feedback or percentage answer weights.

Missing word

The Missing Word format automatically inserts a fill-in-the-blank line (like this _____) in

the middle of the sentence. To use the Missing Word format, place the answers where

you want the line to appear in the sentence.

Moodle costd{~lots of money =nothing ~a small amount} to download from moodle.org.

If the answers come before the closing punctuation mark, a fill-in-the-blank line will be

inserted for the "missing word" format. All question types can be written in the Missing

Word format.

There must be a blank line (double carriage return) separating questions. For clarity, the

answers can be written on separate lines and even indented. Some examples:

Mahatma Gandhi birthday is an Indian holiday on {

~15th

~3rd

=2nd

} of October.

Since {

~495 AD

=1066 AD

~1215 AD



~ 43 AD

}

the town of Hastings England has been "famous with visitors".

Numerical questions

The answer section for Numerical questions must start with a number sign (#).

Numerical answers can include an error margin, which is written following the correct

answer, separated by a colon. So for example, if the correct answer is anything between

1.5 and 2.5, then it would be written as follows {#2:0.5}. This indicates that 2 with an

error margin of 0.5 is correct (i.e., the span from 1.5 to 2.5). If no error margin is

specified, it will be assumed to be zero.

Here is a simple numerical format question. It will accept a range of 5 years.

When was Ulysses S. Grant born?{#1822:5}

It is a good idea to check the margins of the range, 3.141 is not counted as correct and

3.142 is considered in the range.

What is the value of pi (to 3 decimal places)? {#3.14159:0.0005}.

Optionally, numerical answers can be written as a span in the following format

{#MinimumValue..MaximumValue}.

What is the value of pi (to 3 decimal places)? {#3.141..3.142}.

Moodle's browser interface does not support multiple numerical answers, but Moodle's

code can and so does GIFT. This can be used to specify numerical multiple spans, and

can be particularly usefully when combined with percentage weight grades. If multiple

answers are used, they must be separated by an equal sign, like short answer

questions.

When was Ulysses S. Grant born? {#

=1822:0

=%50%1822:2



}

Moodle Attendance

Attendance activity

The Attendance activity is designed for teachers to be able to take attendance during

class, and for students to be able to view their own attendance record.

A teacher can mark the attendance status of a student as "Present", "Absent", "Late", or

"Excused". These status descriptions are configurable, and more can be added. The

teacher adds Attendance as an activity of a course, and then sets up the sessions for

which attendance is to be tracked.

The Attendance activity can generate reports for either the entire class or for individual

students. Students may also see their own attendance record if the activity is not

hidden.

The optional Attendance block allows teachers quick access to the Attendance

functionality, and allows students quick access to a summary report for their own

attendance.

Adding an Attendance activity

An Attendance activity can be added to a course in the same way as any other activity:

Turn editing on

Click 'Add an activity or resource'

Select Attendance

Note that you may now add as many Attendance instances as you like, and that each

instance may have multiple sections. Be sure to give the instance a name that indicates



what it will be used for; for example, "Lecture Attendance". If you will be using groups in

your course, set the Group mode accordingly, because even if groups exist in the

course, you will not be able to use them within the Attendance activity if you select No

groups.

Once you have added an attendance instance, you are ready to start taking attendance

during classes.

Setting Attendance categories and grading options

Now it is time to set your attendance options. Select your attendance activity and you

will see a bar of tabs, the last of which is "Settings." Select "Status set" and you are

presented with acronyms, attendance status descriptions, and grade (points) to assign.

By default, the status descriptions are "Present", "Absent", "Late", and "Excused".

You may prefer to change the descriptions (for example, by changing "Late" to "Tardy"),

change the way points are counted, or add new status descriptions. To do the latter, fill

in the fifth line and click the Add button. Important: when you hit the Add button, any

changes made to existing options that were made after the last time the Update button

was used will be lost. Likewise, when you hit the Update button, any changes made to

the Add after the last time the Add button was used will be lost.

Finally, when you are done changing items on this page, be sure to click

the Update button to register the changes.

Adding sessions

Next, it is time to add sessions. To add class sections, click the Add session tab (second

from left) at the top of the Attendance page. Alternatively, you can click the Add button

from the Attendance block (if you've installed it) to directly navigate to the page for

adding sessions. If you chose "No groups", or have not defined groups, then the

Session type will be forced to "Common." If you have defined groups and have chosen

to use them in your course's Attendance activity, then you will have the option to create

sessions for a group or all students.



You have two options for adding sessions: adding a single session or adding multiple

sessions. The single session is self-explanatory as well as time-consuming to use when

you have many class sessions, so we will go straight to the more useful option.

Check the Create multiple sessions button. Select the date and time for the first session

you wish to add, followed by the duration of the session. Then, enter the date for the

last session you wish to add. Since most classes do not meet seven days a week,

select the checkboxes for days the class meets. The final option, frequency, may look

confusing but it is actually straightforward: if your class meets every week, as is typical,

then you want a frequency of 1 week, which is the default. If your class meets every

other week, then select a frequency of 2 weeks, and so on. If you wish, you may type a

description for the sessions you are creating. If you leave the description field blank, it

will default to "Regular class session". Finally, click the Add multiple sessions button to

create your sessions. You will see a message confirming this.

Editing sessions

Click on the Attendance tab. Here, you will see the list of all attendance sessions you

have added. You can delete an individual session by clicking the X on the session

rectangle's right-hand side. Alternatively, you can check the checkboxes of each

session you wish to delete, and then choose "Delete" from the drop-down menu at the

bottom right-hand corner of the page to delete all the selected sessions.

You can edit a session — for example, to change its date or description — by clicking

the hand icon on the session rectangle's right-hand side.

Taking attendance

Finally, we get to using the activity for its intended purpose. You can take attendance for

a session by clicking on the green radio button on the session rectangle's right-hand

side. Those sessions for which attendance has already been taken, do not have the

green button. However, the description is a link that takes you to a screen for modifying

the attendance record for that session.



Note that when taking attendance, the column headings for attendance status are links.

If you click one of these column headings, all students will have their status changed to

the status you selected. Thus, if everyone is present, you can merely click the P column

header to change everyone's status to "Present". If only one person is absent, you could

first click P to set everyone's status to "Present", and then set the absent student's

status to "Absent".

Enter remarks as appropriate — for example, the reason for an absence if known, or the

number of minutes a student was late — and click the OKbutton to record the

information.

Reports

● You can generate attendance reports on sessions:

● Select the Attendance activity of the course and session you're interested in.

● Click on the Export tab near the top.

● Change the export settings if you wish.

● From the Format pull-down menu, select the file format you'd like to export the

attendance report in.

● Click on the OK button.

● Your browser will now probably ask you to either display or save the file.

One teacher's style of using the Attendance module, useful in those (probably frequent)

situations where there's no access to Moodle in the classroom, is first to take

attendance on paper, and then to transfer the information to Moodle later. To ease this

task, one can print a monthly report before the start of the month and use the printout

for recording attendance during class. This method has the added advantage of having

a picture on the printed report for each student who has uploaded their photo to

Moodle. 



Moodle Feedback

Enabling Feedback Module

Feedback is enabled by default in new installations, but if you don't see it as an option in

your courses, ask the administrator to enable it from Site administration >Plugins

>Activity modules> Manage activities.

Enabling Feedback Block

When added to a course, the Feedback block will display a list of all global Feedback

activities associated with a course. This is helpful for when you want to draw the user's

attention to completing the Feedback activity. Global Feedback activities can be set up

on the front page and can be site wide, or mapped to specific courses. See the section

on mapping feedback to courses below. To enable this block, as an admin, go

to Administration > Site Administration > Plugins > Blocks > Manage blocks.

Feedback administration settings

With the editing turned on,in the section you wish to add your feeback, click the "Add an

activity or resource" link (or, if not present, the "Add an activity" drop down menu )and

choose Feedback. All settings may expanded by clicking the "Expand all" link top right.

https://docs.moodle.org/35/en/Feedback_block


General

General settings expanded by default

● Name

Whatever you type here will form the link learners click on to view the Feedback, so it is

helpful to give it a name that suggests its purpose.

● Description

Add a description of your Feedback instance here. Click the icon top left to expand the

toolbar, and drag the bottom right of the text box out to expand it.

● Display description on the course page

If this box is ticked, the description will appear on the course page just below the name

of the Feedback.



Availability

(These settings are collapsed by default.)

Availability settings expanded

Here you can choose when users can complete feedback.

Question and submission settings

Record User Names



Choose here whether to show the names of users who complete the feedback or not.

Allow multiple submissions

● Choose here whether or not to allow users to complete the feeback more than

once. This is important when using Feedback for anonymous surveys on the

front page as it will allow non-logged in users to complete the feedback.

● Enable notification of submissions

● If set to 'Yes' then teachers will receive notifications when users submit feedback.

● Auto-number questions

● If set to 'Yes' then the questions will be automatically numbered.

● After submission

After submission settings expanded

Show analysis page

The summary results can be shown to respondents, or shown only to teachers.

Completion message

This allows you to present users with apersonalised message after they have answered

the questions.



Link to next activity

This allows you to add a URL to another activity or webpage which you would like them

to go to once they have answered the questions.

Restrict access/Activity completion

(These settings are collapsed by default)

These settings are visible if Conditional activities and Activity completion have been

enabled in the site and the course.

Map feedback to courses

If a feedback instance is added to the front page there is an option, when 'Save and

display" is clicked, to map the feedback to courses. All courses or certain courses may

be selected. (In other words, if you only want the feedback to be available in certain

courses but not all, you would choose just those courses.) The Feedback block can

then be added to those courses and it provides a quick link to the Feedback activity.

Steps to map front page feedback to a course

To map to a course, first type in the name of a course and press the Search button. You

will then be presented with a drop down menu from which you may choose your

course.Click the 'map feedback' button to add it. Repeat this to add another course. If

you don't choose a course then the feedback will be mapped to all courses by default.

https://docs.moodle.org/35/en/Conditional_activities
https://docs.moodle.org/35/en/Activity_completion
https://docs.moodle.org/35/en/Feedback_block


Site administration settings

The feedback module has additional settings which may be changed by an

administrator in Administration > Site administration > Plugins > Activity modules >

Feedback.

Allow full anonymous

Changing this setting to "yes" permits non-logged in users on the front page to complete

a feedback activity.

Feedback capabilities

● Complete a feedback

● Create private template

● Create public template

● Delete completed submissions

● Delete template

● Edit items

● Map courses to global feedbacks

● Receive email notification

● View a feedback

● View the analysis page after submit

● View reports

● Add a new feedback


